The network problem has now been resolved. Should you still experience issues related to this issue, please contact our service desk.
Posted May 20, 2026 - 18:12 CEST
Update
The connectivity problems have dissipated, we are still investigating the cause.
Posted May 20, 2026 - 17:20 CEST
Investigating
We are currenty experiencing connectivity problems within our network which may result in services being unavailable. Our engineers are investigating the cause of the issue and hope to resolve it as soon as possible.